won't start on OSX
 
Notifications
Clear all

won't start on OSX  

  RSS

konsumer
(@konsumer)
New Member
Joined: 2 months ago
Posts: 1
10/08/2020 12:54 am  

I downloaded binary relase for OSX, and after authorizing it to run, it still wouldn't start on Catalina. I ran it in the terminal to figure out the prob, and it looks like it's trying to write to files inside the app bundle:

 

/Volumes/dmg/Artemis.app/Contents/MacOS/Artemis

pygame 1.9.6
Hello from the pygame community. https://www.pygame.org/contribute.html
Traceback (most recent call last):
File "logging/config.py", line 555, in configure
File "logging/config.py", line 728, in configure_handler
File "logging/__init__.py", line 1041, in __init__
File "logging/__init__.py", line 1070, in _open
OSError: [Errno 30] Read-only file system: '/Volumes/dmg/Artemis.app/Contents/MacOS/info.log'

The above exception was the direct cause of the following exception:

Traceback (most recent call last):
File "artemis.py", line 62, in <module>
File "<frozen importlib._bootstrap>", line 983, in _find_and_load
File "<frozen importlib._bootstrap>", line 967, in _find_and_load_unlocked
File "<frozen importlib._bootstrap>", line 677, in _load_unlocked
File "/Users/mbortoli/opt/anaconda3/envs/artemis/lib/python3.7/site-packages/PyInstaller/loader/pyimod03_importers.py", line 489, in exec_module
File "loggingconf.py", line 43, in <module>
logging.config.dictConfig(_LOGGING_CONFIG)
File "logging/config.py", line 792, in dictConfig
File "logging/config.py", line 563, in configure
ValueError: Unable to configure handler 'file'
[7382] Failed to execute script artemis


Quote
MarcoDT
(@marcodt)
Member Admin
Joined: 2 years ago
Posts: 55
17/08/2020 1:33 pm  

Thanks Konsumer for reporting this issue. You can try with this legacy version of the dmg: https://drive.google.com/file/d/1GEw4c8LS6nEZOPoSGW7nNCsFUz614mzm/view

If it still doesn't work out, we'll figure out what's wrong


ReplyQuote
Share: